A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 04:22 PST
Identified
Our upstream cloud infrastructure provider has acknowledged a global issue affecting my sites across the internet. We are closely monitoring the situation and estimate that it will be resolved through the next several hours.
Posted Nov 18, 2025 - 04:01 PST
This incident affected: The LexBlog Platform (LexBlog Platform 1, LexBlog Platform 2, LexBlog Platform 3, LexBlog Platform 4) and Premier Managed Platform, Support Center, LexBlog.com.